RHEL Mensaje de error de assembly luks crypted filesystem en el arranque

Estoy configurando un sistema de files crypt de luks para que se monte en el momento del arranque con RHEL 6.5

Hice toda la configuration desde la command-line y tt funcionó, pero imprimí un post de error después de pedir la contraseña

/crypted is password protected:********* modprobe: FATAL: Error inserting padlock_sha (/lib/modules/2.6.32-431.el6.x86_64/kernel/drivers/crypto/padlock-sha.ko): No such device 

Hice algunas investigaciones y encontré un viejo ticket de RedHat con respecto a esto, uno de los tickets dice que esto es porque ese module es solo para chips Via.

Si configuré el sistema de files encriptados a través de anaconda y no aparece ese post de error, entonces creo que hay algo que omití o no hice bien.

Alguna idea ?

Aquí esta lo que hice

 echo "modprobe dm_crypt" > /etc/sysconfig/modules/load_dm_crypt.modules cryptsetup luksFormat /dev/vg01/lv_crypt cryptsetup luksUUID /dev/vg01/lv_crypt cryptsetup luksOpen /dev/vg01/lv_crypt lv_crypt mkfs -t ext4 /dev/mapper/lv_crypt cat /etc/crypttab [root@server ~]# cat /etc/crypttab lv_crypt UUID=5fd651df-f946-40ab-a07b-47cd63207f3f none [root@server ~]# cat /etc/fstab | grep lv_crypt /dev/mapper/lv_crypt /crypted ext4 defaults 1 2 

Related of "RHEL Mensaje de error de assembly luks crypted filesystem en el arranque"

Ese module kernel está diseñado para soportar hardware criptográfico específico, VIA PadLock . La carga del module fallará cuando no exista una CPU VIA con esas extensiones de encryption.

La pregunta es por qué se intenta cargar ese module en primer lugar. ¿Tienes una CPU VIA? Porque en mi sistema sin uno, el module acelerado sin hardware sha256_generic se carga para mi partición LUKS.

¿Siguió el manual de Red Hat para configurar LUKS y está configurado /etc/crypttab ?