Problemas con Kali Linux 4.6.0-kali1-686-pae

Estoy usando una máquina virtual para ejecutar Kali Linux y cuando ejecuto este command apt-get install -y dkms linux-headers-$(uname -r) me da este error:

 E:Unable to locate package dkms E:Unable to lcoate package linux-headers-4.6.0-kali1-686-pae E:Couldn't find any package by glob 'linux-headers-4.6.0-kali1-686-pae' E:Couldn't find any package by regex 'linux-headers-4.6.0-kali1-686-pae' 

Los contenidos de la variable uname son:

 4.6.0-kali1-686-pae 

¿Cómo puedo solucionar este error? Me impide seguir un tutorial. Cualquier ayuda es muy apreciada 🙂

Solutions Collecting From Web of "Problemas con Kali Linux 4.6.0-kali1-686-pae"

El siguiente error E:Unable to lcoate package linux-headers-4.6.0-kali1-686-pae significa que el package aún no está disponible en el repository activo de kali-linux.

Debe actualizar su versión de kernel y luego instalar el package linux-headers apropiado

Ejecute el siguiente command para descubrir la última linux-image :

 apt update apt-cache search linux-image 

Muestra de salida:

 linux-image-4.9.0-kali3-686-pae linux-headers-4.9.0-kali3-686-pae 

Para instalarlo, ejecuta;

 apt install linux-image-4.9.0-kali3-686-pae 

Reinicia tu sistema y luego instala el package linux-headers :

 apt install linux-headers-4.9.0-kali3-686-pae