No se puede "hacer" una versión anterior de ImageMagick

Necesito instalar una versión 6.9 de ImageMagick para una aplicación anterior de Rails que mantengo (que usa Ruby 1.8.6 en un RVM).

Esto es en una nueva installation de Linux Mint 18.

Descargué un file "ImageMagick-6.9.6-7.tar.gz", lo descomprimí, fui a la carpeta resultante e intenté comstackrlo.

Hubo una gran cantidad de resultados desde el paso ./configure pero parecía lo suficientemente feliz. Sin embargo, make está fallando con muchos resultados: hay toneladas de cosas como esta:

 coders/png.c: In function 'ReadOnePNGImage': coders/png.c:2238:45: warning: passing argument 3 of 'png_set_keep_unknown_chunks' discards 'const' qualifier from pointer target type [-Wdiscarded-qualifiers] png_set_keep_unknown_chunks(ping, 1, mng_iCCP, 1); ^ In file included from /usr/include/libpng12/png.h:321:0, from coders/png.c:101: /usr/include/libpng12/png.h:2330:25: note: expected 'png_bytep {aka unsigned char *}' but argument is of type 'const png_byte * {aka const unsigned char *}' extern PNG_EXPORT(void, png_set_keep_unknown_chunks) PNGARG((png_structp 

etc.

Dado que esta es una nueva installation, sospecho que podría estar perdiendo alguna herramienta de compilation o utilidades de desarrollo o algo así. ¿Alguien puede ayudar? Lo siento si esto es un poco vago.

EDIT: una list completa de los packages que he instalado: http://pastebin.com/bJg4qC0M

EDIT 2: salida completa de make : http://pastebin.com/qXu5FUC4

EDIT 3: salida de make install : http://pastebin.com/5TPeQScp

Related of "No se puede "hacer" una versión anterior de ImageMagick"