Montaje de ExFAT en Linux

He intentado configurar mi Raspberry Pi B + como un HTPC que también comparte un disco duro USB sobre Samba y AFP. El último está funcionando bien, y la cuota de Samba también parecía estar funcionando por un momento. Sin embargo, cada vez que trato de conectarme al Pi ahora (sin modificaciones AFAIK), me muestra las carpetas con icons de parada pequeños. Desafortunadamente, los siguientes enlaces no me ofrecieron ninguna ayuda.

  • Monte el sistema de files exFAT como usuario sin especificar / dev / sdX1 en / etc / fstab
  • No puedo montar exFAT aunque instalé exfat-fusible

initialization

sudo mkdir /mnt/Data sudo chown osmc:osmc /mnt/Data sudo chmod -R 777 /mnt/Data sudo apt-get install exfat-fuse exfat-utils 

montar

 /dev/sdb2 on /mnt/Backups type hfsplus (rw,nosuid,nodev,noexec,relatime,umask=22,uid=1000,gid=0,nls=utf8) /dev/sdb1 on /media/EFI type vfat (rw,nosuid,nodev,relatime,uid=1000,gid=1000,fmask=0111,dmask=0000,allow_utime=0022,codepage=437,iocharset=ascii,shortname=mixed,showexec,utf8,errors=remount-ro,uhelper=udisks) /dev/sdb3 on /mnt/Data type fuseblk (rw,nosuid,nodev,relatime,user_id=0,group_id=0,allow_other,blksize=4096) 

cat / proc / filesystems | Fusible grep

  fuseblk nodev fuse nodev fusectl 

blkid

 /dev/sdb3: LABEL="Data" UUID="5563-32E4" TYPE="exfat" PARTLABEL="Data" PARTUUID="91a3c291-cfcf-4b17-ba57-538c29c3f951" 

fdisk -l

 Disk /dev/sdb: 2,7 TiB, 3000592977920 bytes, 732566645 sectors Units: sectors of 1 * 4096 = 4096 bytes Sector size (logical/physical): 4096 bytes / 4096 bytes I/O size (minimum/optimal): 4096 bytes / 4096 bytes Disklabel type: gpt Disk identifier: C5BDA252-07EB-4C54-B1EF-35AC14D16381 Device Start End Sectors Size Type /dev/sdb1 6 76805 76800 300M EFI System /dev/sdb2 76806 244217437 244140632 931,3G Apple HFS/HFS+ /dev/sdb3 244250368 732566527 488316160 1,8T Microsoft basic data 

cat / etc / fstab

 /dev/mmcblk0p1 /boot vfat defaults,noatime 0 0 /dev/mmcblk0p2 / ext4 defaults,noatime 0 0 UUID=eae6464d-bd99-39f5-91a9-7d41b61356d4 /mnt/Backups hfsplus rw,force,exec,auto,users 0 3 UUID=5563-32E4 /mnt/Data exfat rw,force,exec,auto,user,umask=0 0 0 

He intentado lo siguiente:

  • cambiando "exfat" en / etc / fstab a "fuse-exfat", "exfat-fusible", "fuseblk". Todo sin suerte.
  • assembly manual usando:

    • sudo mount / dev / sdb3 / mnt / Data
    • sudo mount -t exfat / dev / sdb3 / mnt / Data
    • sudo mount -t exfat-fuse / dev / sdb3 / mnt / Data
    • sudo mount.exfat / dev / sdb3 / mnt / Data
    • sudo mount.exfat-fuse / dev / sdb3 / mnt / Data

/etc/samba/smb.conf

 [global] workgroup = HOME server string = %h server dns proxy = no log file = /var/log/samba/log.%m max log size = 1000 syslog = 0 panic action = /usr/share/samba/panic-action %d security = user encrypt passwords = true passdb backend = tdbsam obey pam restrictions = yes unix password sync = yes passwd program = /usr/bin/passwd %u passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* . pam password change = yes map to guest = bad user usershare allow guests = no [homes] comment = OSMC # browseable = no path = /home/osmc/ valid users = @users, root, osmc ###this seemed necessary according to a guide force group = users create mask = 0777 directory mask = 0777 read only = no 

Lo gracioso es, en cada uno de estos commands. Los privilegios / mnt / Data cambian a (drwxr-xr-x, raíz: raíz) y vuelven a la normalidad cuando desmonte el volumen. Supongo que OS X no me permitirá search en ningún directory ya que es propiedad de root y me estoy conectando como osmc. ¿Qué parece estar yendo mal aquí?

Saludos, Rowan Kaag

Solutions Collecting From Web of "Montaje de ExFAT en Linux"

Noté que, de manera pnetworkingeterminada, OSMC también comparte HDD externos sobre Samba. Al conectarme a la Raspberry a través de Samba, obtengo las siguientes opciones:

  • osmc
  • hogares (no relevante en este caso)
  • Datos (partición ExFat en HDD)

Cuando me osmc a osmc , desde mi entender, me sirve /home/osmc que tiene carpetas /home/osmc que puse allí, por ejemplo: /home/osmc/Movies -> /mnt/Data/Movies

Esto resulta en el comportamiento que mencioné antes, dándome círculos de advertencia rojos en las carpetas. Sin embargo, cuando se conecta directamente a 'Datos', todo funciona bien. Pensé que esto me sentaría bien y que no me molestaría esperar una respuesta porque soy muy impaciente.