Articles of package management

Verifique si CVE-2016-10229 está arreglado en mi server XEN Debian Linux

Uso Debian jessie en un server Xen y ahora estoy preocupado por el problema CVE-2016-10229 : udp.c en el kernel de Linux anterior a 4.5 permite a los atacantes remotos ejecutar código arbitrario a través del tráfico UDP que desencadena un segundo cálculo inseguro de la sum de comprobación durante la ejecución de una llamada […]

Problemas al desinstalar gnome-builder

Instalé el nuevo generador de gnomos hace un time (en realidad alguien lo hizo por mí) y ya no lo necesito. Pero cuando intentas unistall a través de la línea de command o sináptica, aparece como el progtwig no está instalado; pero puedo abrirlo normalmente ¿Cómo puedo desinstalarlo? Algunas fotos para get información adicional:

Cómo degradar ZFS en Linux en CentOS

Necesito hacer algunas testings de ZFS en CentOS 7.3 usando la twig 0.6.5, no la twig 0.7x. Cuando instalo usando las instrucciones del sitio ZoL para el package "zfs-release", solo veo lists para las versiones 0.7x. Prefiero usar la installation de kmod también, solo fyi, pero creo que una vez que resuelva el control de […]

El instalador del package de GUI de Fedora tarda mucho (> 15min) en iniciarse

Traté de usar la GUI de Linux para Fedora pero no la encontré intuitiva como la de Windows. Cada vez que intenté instalar cualquier software usando el file rpm haciendo doble clic en el file, muchas veces se bloqueó y cuando lo reinvoco del terminal dice que yum ya está bloqueado y que ya se […]

Instalar MySQL workbench en ubuntu

Estoy usando Ubuntu 9.10 – el Koala Kármico – lanzado en octubre de 2009 Descargué mysql-workbench-gpl-5.2.33b-1ubu1004-i386.deb desde aquí Pero cuando ejecuto este package me muestra el siguiente error: Error: Dependency is not satisfiable: libatk1.0-0 (>= 1.29.3) Soy nuevo en ubuntu. He intentado muchos packages pero no he podido instalar MySQL Workbench. ¿Cómo puedo instalarlo en […]

¿Agregar el repository mono de openSuSe?

Pregunta: Quiero instalar mono3 desde aquí: http://download.mono-project.com/archive/3.0.3/linux/x64/ ¿Cómo puedo agregar este enlace al progtwig de installation del package OpenSuse apropiado? Intenté zypper ar http://download.mono-project.com/archive/3.0.3/linux/x64/ mono3 pero eso produce "El tipo de repository no se puede determinar". El repository mono3 no es válido.

apt-get dist-upgrade quiere eliminar demasiados packages

Estoy actualizando de Mint 13 a Mint 15 usando apt-get dist-upgrade . Quiere eliminar 277 packages, que encuentro bastante. Entre esos packages se encuentran acroread, xmlcopyeditor, wine1.4, skype y otros. ¿Puedo evitar eliminar estos packages o no tengo otra opción? La herramienta también dice The following packages have been kept back: cpp g++ g++-multilib gcc […]

¿Cómo puedo crear fdupes desde la fuente en Ubuntu?

Me gustaría hacer algunos cambios en el código fdupes. Sé que puedo tomar el código fuente del website, pero ¿hay una forma mejor en Ubuntu / Debian? Después de get la fuente de esta manera, ¿dónde está almacenada? Si uno quisiera hacer cambios en el código y recomstackr / instalar, ¿cómo se hace? ¿Hay una […]

¿Puedo confiar en packages binarys (pkg) en FreeBSD?

Desde el pasado octubre, los packages binarys han estado disponibles para FreeBSD ( http://lists.freebsd.org/pipermail/freebsd-pkg/2013-October/000107.html ). Antes de eso, tenían problemas para evitar que se publicaran packages binarys. En este momento, ¿hay alguna razón para no confiar en los espejos de los packages binarys? ¿Hay alguna posibilidad de que se detecte una infracción de security y […]

Enumerar los commands ejecutados por el package rpm

Perdón por la pregunta muy básica, tal vez mi gramática de Google no sea la mejor esta noche. Estoy tratando de dividir un package de rpm en una list de commands (no solo su contenido de file). Me gustaría saber qué es todo y en qué order se ejecuta cuando se ejecuta yum install –nogpgcheck […]