Articles of dependencies de

instalar packages con las dependencies más antiguas

Sistema: Debian GNU / Linux 8 (jessie) de 64 bits uname -r: 4.9.0-0.bpo.1-amd64 Bueno, actualicé kernel a 4.9. Y actualicé todos mis packages. Pero ahora estoy tratando de instalar la biblioteca skype y gtk3, y tengo un problema de dependencies. Para instalar Skype, hago esto: sudo dpkg –add-architecture i386 sudo aptitude update wget -O skype-install.deb […]

¿Qué fonts componen el package dotnet-sdk-2.0.2?

He instalado dotnet-sdk-2.0.2 .NET SDK como está empaquetado para Debian, pero no puedo encontrar los packages fuente. ¿Qué fonts se utilizan para comstackr este package y sus dependencies? Me imagino que incluye https://github.com/dotnet/sdk , pero también otros.

Copia de security de un package en particular y sus dependencies

Mi pregunta es: ¿podemos hacer una copy de security de un package en particular y sus dependencies? Por ejemplo, si instalamos VLC, se requieren dependencies como kde filesystem, libcaca.so.0, etc. ¿podemos hacer una copy de security de VLC y sus dependencies? Estoy usando Fedora15

¿Cómo puedo solucionar este error de dependencia al actualizar clamav usando yum?

Estoy intentando actualizar clamav en una antigua installation de server de correo de CentOS 5, pero sigo recibiendo un error de dependencia que no puedo entender. Seguí el método descrito aquí . Tal vez alguien me puede mostrar el path a través de esto? [root@s1 ~]# yum list clamav Loaded plugins: fastestmirror, priorities Loading mirror […]

Instalando RPMS en Centos

¿Generalmente se están instalando rpms independientes considerados 'peligrosos'? ¿Se ven afectados por las actualizaciones del sistema, las actualizaciones de packages, etc.? ¿Qué hay de las dependencies y las bibliotecas?

Los siguientes packages tienen dependencies no satisdates

Cada vez que trato de usar apt-get install o eliminar o purgar en mi Debian, aparece este error: The following packages have unmet dependencies: libimage-magick-q16-perl : Depends: libmagickcore-6.q16-2 (>= 8:6.8.9.9) but it is not going to be installed libmagick++-6.q16-5 : Depends: libmagickcore-6.q16-2 (>= 8:6.8.9.9) but it is not going to be installed Depends: libmagickwand-6.q16-2 (>= […]

¿Tiene dnf un equivalente al "build-dep" de apt?

algo como sudo apt build-dep apache Supuestamente instala todas las dependencies necesarias para build apache desde el origen (nunca lo he usado antes). ¿Hay un command equivalente para el administrador de packages dnf ?

Dependencias fallidas

Estoy buscando lo siguiente: libpython2.5.so.1.0 libtinfo.so.5 python (abi) = 2.5 Busqué, pero no puedo encontrarlos. Estoy ejecutando Centos 5.6 con Linux kernel 2.6.18-238.el5. $ rpm -q –provides python | grep -Fw 'python(abi)' python(abi) = 2.4 Por lo que busqué, libtinfo.so.5 es una parte de la biblioteca de ncurses ahora. Pero está buscando esa biblioteca de […]

RPM: la dependencia de jre falló, aunque esa versión de JRE está instalada

Estoy intentando instalar un package y falla al informar una dependencia faltante: # rpm -ivh * error: Failed dependencies: jre >= 1.7.0 is needed by Tomcat-7.0.37-1.noarch Al mismo time, cuando reviso mi versión de Java, esto es lo que obtengo: # java -version java version "1.7.0_40" Java(TM) SE Runtime Environment (build 1.7.0_40-b43) Java HotSpot(TM) Server […]

¿El empaquetado de una aplicación para APT implica apuntar a la aplicación para usar las dependencies comunales de APT?

Recientemente descubrí que las distribuciones basadas en Debian esencialmente tienen una colección fija de dependencies y bibliotecas comunales que cualquier aplicación instalada a través de un administrador de packages debe usar. Contraste esto contra, digamos, Windows, donde creo que cada aplicación generalmente proporciona sus propias dependencies, y por lo tanto una installation del sistema operativo […]