Articles of dependencies

¿Por qué gedit necesita libbluray?

Perdónenme si esto es algo que "todo el mundo sabe", pero gedit (el editor de text gnome gui) tiene una dependencia en libbluray. Busqué en Google y leí las notas de la versión de gedit, sin suerte, y no puedo pensar en una razón legítima para esto. Estoy usando RHEL7 Workstation, pero sospecho que cualquier […]

CentOS 6 instala libmysqlclient.so.16 y amigos sin que yo pregunte

Mientras trataba de resolver un problema de dependencia con las bibliotecas libmysqlclient de MySQL en uno de mis serveres MySQL CentOS 6, me sorprendió descubrir las siguientes bibliotecas instaladas en /usr/lib/mysql : libmysqlclient_r.so -> libmysqlclient_r.so.16.0.0 libmysqlclient_r.so.16 -> libmysqlclient_r.so.16.0.0 libmysqlclient_r.so.16.0.0 libmysqlclient.so -> libmysqlclient.so.16.0.0 libmysqlclient.so.16 -> libmysqlclient.so.16.0.0 libmysqlclient.so.16.0.0 La razón por la que me sorprendió fue porque […]

problemas al instalar lcov en Debian 6

He estado atascado durante unas horas tratando de instalar lcov en una caja Debian 6. ¡Cualquier ayuda sería muy apreciada! Lo que he intentado lo siguiente en la línea de command: root@damrod-ci:/etc/munin/plugins# apt-get install lcov Reading package lists… Done Building dependency tree Reading state information… Done You might want to run `apt-get -f install' to […]

¿Por qué yum-builddep no proporcionó las dependencies para instalar mi rpm?

Estoy tratando de ron mi package de rpm pero obteniendo este error de dependencies. [root@localhost ~]# rpm -ivh /root/x86_64/asterisk-1.8.12.2-1.fc15.x86_64.rpm error: Failed dependencies: libc.so.6(GLIBC_2.14)(64bit) is needed by asterisk-1.8.12.2-1.fc15.x86_64 libc.so.6(GLIBC_2.7)(64bit) is needed by asterisk-1.8.12.2-1.fc15.x86_64 libc.so.6(GLIBC_2.8)(64bit) is needed by asterisk-1.8.12.2-1.fc15.x86_64 libcap.so.2()(64bit) is needed by asterisk-1.8.12.2-1.fc15.x86_64 libcrypto.so.10()(64bit) is needed by asterisk-1.8.12.2-1.fc15.x86_64 libedit.so.0()(64bit) is needed by asterisk-1.8.12.2-1.fc15.x86_64 libgsm.so.1()(64bit) is needed […]

Instalación de marionetas en RHEL6

Al instalar Puppet en RHEL6, recibo los siguientes errores. Aunque he instalado gems de Ruby, tengo problemas con las dependencies de ruby ​​gems. ¿Cómo resuelvo este problema? [root@INFINI-ONE ~]# yum install puppet Loaded plugins: product-id, subscription-manager Updating Red Hat repositories. core-0 | 1.8 kB 00:00 core-1 | 1.8 kB 00:00 core-2 | 1.8 kB 00:00 […]

¿Cómo diferenciar dependencies de compilation y dependencies de uso?

Algunas dependencies de packages solo son necesarias para la compilation, mientras que otras son necesarias para el uso real. Como ejemplo, sé que net-misc/unison dev-lang/ocaml requiere dev-lang/ocaml solo para la compilation, mientras que su dependencia sys-libs/glibc es (también) para el uso. ¿Pero cómo se puede descubrir la diferencia?

¿Cómo puedo instalar todas las bibliotecas perdidas de Perl?

Estoy intentando instalar logitechmediaserver 7.8.0 en mi OSMC (Raspbmc) Raspberry Pi. Principalmente seguí las instrucciones desde aquí , aunque parte de la installation no funcionó (algunas dependencies faltaban en los repositorys y el parche falló). A pesar de todo, llegué a la parte donde reinicio el server con el sudo service logitechmediaserver start , luego […]

Dependencias de Debian para ttyecho

¿Qué dependencies debe tener un package Debian, que distribuye el binary de ttyecho ?

yum instalar R problema de dependencia (RHEL 5.5)

Intento instalar R de forma remota en un sistema RHEL 5.5 pero sigo teniendo un problema de dependencia yum -y install R resultados en el siguiente Loaded plugins: rhnplugin, security This system is not registenetworking with RHN. RHN support will be disabled. Setting up Install Process Resolving Dependencies –> Running transaction check —> Package R.x86_64 […]

El software depende de una versión anterior del package, que MINT 18 usos

Estoy ejecutando Mint 18 y quiero instalar la extensión de administrador de networking SSTP + ( http://sstp-client.sourceforge.net ). El problema al que me estoy enfrentando es que la extensión de networking mgr depende de " ppp versión 2.4.6 " Y Mint 18 usa " ppp versión 2.4.7 ", que tiene bibliotecas y software que depende […]